Carver Fanmaster Heater

Status
Not open for further replies.
Mar 14, 2005
12
0
0
Visit site
I have a 2000 Avondale Avocet fitted with a Carver 5500 Turbo Fanmaster heater. When used with mains electricity, it is has two sliding controls, one is the thermostat and the other is the options switch.

I have no problem when the options switch is set at convection but after a little while, when the two further options are used which control the blower speed, the blowers begin to race out of control. The whole thing makes a dreadful noise and vibrates, forcing me to turn it off

Any suggestion please?
 
Mar 14, 2005
1,158
41
19,185
Visit site
First of course it should not race out of control although it will speed up and down quite a lot on the last setting, less so on the one before.The fan speed is governed by the heat produced and the last setting is 0.9 to 1.8kw the lower and convector setting a maximum of 0.9kw. Because of the design of the switch I would first suspect this or the connections too it, do all the lights work?. I hate saying this but it is just as likely the main control board

is at fault, I say hate because it's a catch all that covers everything else bar the fan motor which it is unlikely to be. One crazy problem I did find on a 5500 is a component 'falling' off the control board probably due to the battery being connected the wrong way round. In itself the board still worked fine until the loose component moved and shorted others out. Switches are now in very short supply, dealer stock being all that is available new. If you have any problems contact www.arcsystems.biz
 
Mar 14, 2005
30
0
0
Visit site
I had this same problem on my Avocet. The problem was caused by the blower unit bocoming dislodged from the heater housing. I tried to resolve it by tightening the locating tabs on the housing where the blower unit is located and this worked for a while but eventually the problem recurred. It sounds drastic but I relocated the blower unit in position in the housing and secured it with a short self tapper. No more trouble!!
 
Thank you Gary and Mick for your advice. I have only tried to sort out the problem this week.

Mick - the fan had become dislodged from its housing at the back. I have managed to relocate it but fancy that it will reoccur due to vibration. It is difficult to get at and I am reluctant to remove the whole unit but I will try to fix a set screw which will no doubt help.

Gary - the fan although now silent still races away. You are right the sliding control has been discontinued. I will try arcsystems and maybe ring round a few dealers on the off chance.

If any reader of this posting knows where I could get a replacement I would be grateful.

Regards

Norman
 
Mar 14, 2005
12
0
0
Visit site
This is a follow up to my posting of the 19th Feb. I have today been to the Caravan Show at the NEC. Truma have had made 5000 of the electronic devices attached to the slider control. The sliders themselves are still not available.

These devices should be in the dealers shortly but are available by mail order from www.miriad-products.com of Burton on Trent 01283 511883 for just over
 
Jul 14, 2023
4
0
10
Visit site
Hi guys I'm new to this. I have just purchased a van with a carver 5500 fanmaster.
The slider works and the fan comes on but no heat. Also I think the igniter for the gas doesn't work but should it still work on mains or battery power.?
Any help appreciated
 
Status
Not open for further replies.

TRENDING THREADS

Latest posts