Indicator/Flasher Problem

Jun 13, 2024
3
0
10
Visit site
I recently exchanged my 2016 Sterling Continental for a new Swift Challenger SE and this is towed by a 2015 Jaguar XF Sportbrake. No problems with the previous van, but my indicators don't always work with the new van. Both car and caravan have been tested by professionals and both say there is no problem with either. To make the indicators work, I have discovered that if I press the indicator stalk very lightly, it starts to flash properly and then continue to fully press, it works and continues to work until the car engine is switched off. Restart the car and it's back to not working. Sometimes it quits mid journey which is a bit uncomfortable. 13 pin wiring sockets are both OK and join properly. Indicators on car and caravan are both LED lights. Can anyone advise how I can solve this problem.

Anyone interested can view via link below

 
Nov 11, 2009
21,073
6,640
50,935
Visit site
Hi welcome to the Forum, it’s a not uncommon issue when a newer van is connected up. Here’s a link to an earlier but recent post with issues too. May shed some light, if you forgive the pun 😂

 
Last edited:
Jun 13, 2024
3
0
10
Visit site
Thanks for that. I had searched but did not find this thread. My gut feeling is that car and caravan are both ok, but if power is switched in too quickly relays or whatever can’t take it and opt out and when power is applied lightly it is accepted. Any electrician’s opinions would be welcomed.
 

JRT

May 5, 2024
248
167
135
Visit site
Speak to Sargent about fitting one of these.


I had to fit the older version when I towed with an Antara then when I swapped to my current Kuga had to remove it.

The LED lights on Swifts do seem to trigger all sorts of weird and wonderful 'faults' with some vehicles.

I do recommend speaking to them because I found the web site info. regards compatibility was not fully up to date.
 
  • Like
Reactions: otherclive
Jun 13, 2024
3
0
10
Visit site
Thanks for the link. I had something similar fitted a few years ago. LED on van, not on older Citroen. Not quite the same. I will speak to Sargent asap. Better be sure before forking out £155.
 

TRENDING THREADS

Latest posts