USB socket in 2021 Sprite Alpine 2

Aug 23, 2020
1
0
10
Visit site
Just took delivery of a new Alpine 2.

It's got a pod along the front window with six Berker blanks for mains sockets, usb sockets etc. As delivered, you get one mains socket and one twin USB socket.

Plugged the phone into the USB socket yesterday and was surprised to see it charging at only 400mA. It's supposed to be rated at 2.1A according to the replacement socket on the Sargent Electrical website, so wondering why this should be.

Took phone indoors and plugged it into one of my mains sockets that are fitted with 2.1A USB sockets - it read 1600mA charge.

Anyone had similar?
 
May 7, 2012
8,598
1,816
30,935
Visit site
If it is the socket you could complain to the dealer as the caravan is not up to the advertised spec and ask them to correct it. The point is probably not worth asking for your money back even assuming you are within thirty days of purchase. I assume from what you say though that you tested the output end of the cable, and it may be the cable that is the problem so check at the socket.
 
Aug 23, 2020
1
0
10
Visit site
Found out that prior to 2021, 0.5A USB sockets were fitted in the front pod (pretty much useless for todays smartphones and ipads). 2021 models should have had 2.5A USB sockets fitted. I've gone back to the dealer, so I'll see what he says.
 
Oct 3, 2013
890
90
18,935
Visit site
Just took delivery of a new Alpine 2.

It's got a pod along the front window with six Berker blanks for mains sockets, usb sockets etc. As delivered, you get one mains socket and one twin USB socket.

Plugged the phone into the USB socket yesterday and was surprised to see it charging at only 400mA. It's supposed to be rated at 2.1A according to the replacement socket on the Sargent Electrical website, so wondering why this should be.

Took phone indoors and plugged it into one of my mains sockets that are fitted with 2.1A USB sockets - it read 1600mA charge.

Anyone had similar?
It's still not 2.1 amps
 
Oct 3, 2013
890
90
18,935
Visit site
Just took delivery of a new Alpine 2.

It's got a pod along the front window with six Berker blanks for mains sockets, usb sockets etc. As delivered, you get one mains socket and one twin USB socket.

Plugged the phone into the USB socket yesterday and was surprised to see it charging at only 400mA. It's supposed to be rated at 2.1A according to the replacement socket on the Sargent Electrical website, so wondering why this should be.

Took phone indoors and plugged it into one of my mains sockets that are fitted with 2.1A USB sockets - it read 1600mA charge.

Anyone had similar?
A battery will only take what current it requires.Could be battery only requires 400mA
 
May 24, 2014
3,687
765
20,935
Visit site
You state that you plugged it into the mains socket that has USB ports, but did you connect with the USB cable or a three pin plug, or even the fast charger plug that came with your phone. There will be a difference in all three scenarios.
 

TRENDING THREADS

Latest posts