Propex q1600 Fan Heater

Mar 1, 2015
13
0
0
Visit site
Its the first time I have used the Fan heater since I purchased my 1990 Talbot Express Motor Home, although the heater ignites and stays on for a few minutes it then cuts off. Any ideas how to get the heater to stay on I have tried turning the thermostat up but it does not make any different.
Glen
 
Jan 23, 2011
236
0
0
Visit site
Hi Glen looking at the Propex site these were discontinued in 1999 due to changes in legislation, so spares may be a problem now. There are contact details on their website so an enquiry direct to them may be your best solution.
http://www.propexheatsource.co.uk/about
 
Jan 23, 2011
236
0
0
Visit site
Had a rethink on your problem Glen. Is there a thermocouple fitted just beyond the tip of the flame ?? If so it could be that which has burnt away & it would close the gas supply.
 
Mar 1, 2015
13
0
0
Visit site
Flicka said:
Had a rethink on your problem Glen. Is there a thermocouple fitted just beyond the tip of the flame ?? If so it could be that which has burnt away & it would close the gas supply.

Thanks for your reply.
I have spoken to Propex and they have said it is not the thermostat that's faulty and they said it will be in the heater it self ( they did mention something about the thermocouple ) but I would have to send the heater to them. As we use electric hook-ups we do not need to use the heater as we have a small fan heater.
I was hoping it would be something small and easy to repair, but it isn't.
Glen
 

Latest posts