Shurflo Water Pump

May 25, 2005
25
0
0
Visit site
Our Avondale is fitted with a Shurflo water pump which has been

replaced once under warranty however when the cold tap is turned on we continue to get hot water out of the cold tap - not nice when brushing your teeth has anyone else experienced this problem the dealer says they cannot find anything wrong
 
Mar 14, 2005
17,847
3,221
50,935
Visit site
Hello Ann,

The water pump only pumps the cold supply, so if you are getting hot water as well then that clearly indicates that something else is wrong.

Do you have a shower in the caravan that has mixer valve and a separate flow valve or trigger on the hand set? If you have, then it is possible for the mixer valve to be allowing cross flow between the hot and cold systems. Either turn the mix valve off or have non-return valves fitted into both hot and cold pipes just before the mixer valve.

Another possibility is the water heater. These usually have a non-return valve in the cold feed to the heater. If the valve is faulty, then the pump will fill up the heater and cold pipes and pressurise them. As the heater warms up it increases the pressure (expansion of water) so when a tap is opened the pressure in the heater forces hot water back into the cold pipework until the pressure drops below the trigger point of the water pump.

Hope this helps
 
Mar 14, 2005
1,159
41
19,185
Visit site
I agree John, my money would be on a faulty non-return valve in the water heaters cold water inlet.

One other thought is I know 'Whale' pumps of this type are set to maximum pressure (50psi!!)when new, this needs to be adjusted down to about 12psi for the average caravan when fitted. I wonder if the Surflo is the same and the excessive pressure could in some way create the fault, I doubt it really but it's worth mentioning as high pressure can cause problems in in other ways if not adjusted.
 
Mar 14, 2005
17,847
3,221
50,935
Visit site
I agree John, my money would be on a faulty non-return valve in the water heaters cold water inlet.

One other thought is I know 'Whale' pumps of this type are set to maximum pressure (50psi!!)when new, this needs to be adjusted down to about 12psi for the average caravan when fitted. I wonder if the Surflo is the same and the excessive pressure could in some way create the fault, I doubt it really but it's worth mentioning as high pressure can cause problems in in other ways if not adjusted.
Hi Gary,

I seem to recall that sureflow pumps sold for the caravan market are already set to about 1.5 bar - I could be wrong, but if a 50psi pump was used there would be other tell tale signs such as weeping from the over pressure valves in the water heater, joints actually parting or taps leaking.
 
Mar 14, 2005
1,159
41
19,185
Visit site
Hi Gary,

I seem to recall that sureflow pumps sold for the caravan market are already set to about 1.5 bar - I could be wrong, but if a 50psi pump was used there would be other tell tale signs such as weeping from the over pressure valves in the water heater, joints actually parting or taps leaking.
I agree John that's why I think it unlikely but having 're-conned' a cascade and then had the customer shouting down the phone that it still leaked and I test to 30psi!?..I just thought it was worth mentioning
 
May 25, 2005
25
0
0
Visit site
Hi Ann,

Have you resolved teh problem yet, Please let us know.
after going round the houses, the dealer would not accept the probelm i went direct to avondale whom said they should fit a non return valve and are sending the part to the dealer to be fitted - so its not cured yet fingers crossed
 

TRENDING THREADS

Latest posts