Truma E514H error message.

Jun 16, 2010
361
161
18,735
Visit site
Something of an annoyance this, so hopefully someone can help!

When firing up the heating / hot water via the Truma control panel, i'm getting this flashing E514H message on the screen.

After about 15 mins of flashing, it allows me to turn everything back on again and its business as usual.

Having a read around the internet, the suggestion is that this happens when the heating has not been shut down correctly (for example, unplugging the EHU while the heating is on). So a quick flick through the manual tells me that i need to turn it off by pushing in the control knob for 2 seconds.

Having done that and it all being shut down correctly, when i tried to use it earlier, i got the same E514H message flashing away for 15 minutes!

So please, where am i going wrong here !
 
Nov 16, 2015
10,733
3,043
40,935
Visit site
Did you read about removing the panel on the heater and resetting. ?

I dont know the unit just found the info.
 
Jun 17, 2011
826
27
18,885
Visit site
A suggestion, try rebooting the whole system. You can do this by disconnecting battery, with no mains connected. Leave it 20 mins and reconnect. Switch on the panel with mains connected. You can just remove the fuse on the fuse box but I did this and dropped it. Hell of a game recovering it, boss had to use her tweezers.
 
Jan 7, 2016
6
0
10,510
Visit site
This is an annoying problem but is easy to avoid - you get an E514H error if you turn off the mains power without shutting down the heating and hot water first. Its a very common problem when you pick up the caravan because as part of the handover they demonstrate the heating and then pull the power before using the control panel to turn off the heating and the hot water. As previously commented if you get an E514H error then you just wait for 15 minutes until it stops flashing and then clear it on the control panel.
 
May 7, 2012
8,598
1,816
30,935
Visit site
If the power is only on electric switch it to mixed. It has worked for us on our last two caravans. It runs on electricity anyway unless you need the gas as well, so there is no cost to it.
 

TRENDING THREADS

Latest posts