Another C250 Problem

Jun 11, 2012
1,524
27
19,685
Visit site
Hi All Sir Roger in trouble with the Thetford C250 Toilet flush This has been an issue with our van from about a year after we bought it, for some unknown reason the PCB on the top keeps breaking down. While we were away last week found we had no flush again so on return home I have bought another PCB but still have no flush Now I have removed the cassette and checked the fuse that was blown and badly corroded so I have replaced the fuse 3 amp and I still have no flush, so back into the cassette housing and went to the reed switch only to find one of the main contacts no longer exist and the reed switch one end detached from the board.I have now completely removed the reed switch I need to know if this is replaced with a new one will that give me my flush back or is that just for full light alone . Im now looking at running a cable down the van and fitting another switch and forgetting the full light you when the toilets full Im sure .Has anybody else done this . Thank you all
Sir Roger
 
Nov 11, 2009
20,885
6,534
50,935
Visit site
The C250 was an appalling piece of design. Don’t know about the reed switch as we just look into the loo cassette to check level. But you could check the pump as sometimes they will stick and can be freed by turning.
 
Oct 17, 2010
1,247
487
19,435
Visit site
As Clive I'm the same, just have a look at the level in tank, my full light hasn't worked for ages and I'm still able to flush. (toilet that is) Had to replace my PCB the last time it didn't flush.

PS Used some car windrscreen wash over winter, to stop pump from freezing, spins like a good un now.
 
Nov 11, 2009
20,885
6,534
50,935
Visit site
DaveA1 said:
As Clive I'm the same, just have a look at the level in tank, my full light hasn't worked for ages and I'm still able to flush. (toilet that is) Had to replace my PCB the last time it didn't flush.

PS Used some car windrscreen wash over winter, to stop pump from freezing, spins like a good un now.

Yes I also pump through some windscreen wash for protection in winter.
 
Jun 11, 2012
1,524
27
19,685
Visit site
Just a quick thank you to those who replied to my C250 issue. I have been back to our van over the week end and found the problem. It was a ll down to a previous problem quite some time ago. I had to fit a new pump and found over the weekend that the connectors I used despite using insulation tape moisture had got to the connections. Switch cleaner and clean up jobs a good un. Thank you for your post in order to help.
Sir Roger
 

TRENDING THREADS

Latest posts