Thetford CW 200 CW toilet holding tank

Mar 14, 2005
3,027
40
20,685
Visit site
The holding tank of my CW 200 has develped a leak (pardon the pun) around the operating lever of the blade seal - the yellow button on the tank which engages with the lever on the side of the toilet proper.

This means that if the tank is more than about half full when taken out and lifted vertically for carrying to the dump, there is a constant stream of liquid from around this button - obviously not acceptable. the lip seal itself is fine and water tight.

The instruction book shows a complete blage and operator unit but with no Part Number as a spare, and I suspect this unit may be fitted before the bottom of the holding tank is (solvent ?) welded on.

Has anyone else had this problem and is there any cure apart from buying a new tank ( or emptying before it gets more than half full). To add confusion, my instruction book shows two part numbers for spare holding tanks 23719 and 23787 - and ideas on how I find out which one I need ?

Finally, any suggestions as to the chepest source for such things - if the price of lip seals is anything to go by, I guess it could be well over £100. Thanks in advance for any assistance.
 
Mar 14, 2005
4,638
0
0
Visit site
Most caravan dealers should be able to supply the part .

We had a problem with the air bleed yellow button leaking and got the part from a remote camping supplies in Scotland.
 
Mar 14, 2005
3,027
40
20,685
Visit site
Can now answer my own question - perhaps of interest to others.

Blade operator is readily available as a spare at around
 

TRENDING THREADS