Battery Terminal Corrosion and New Battery.

May 15, 2016
111
4
18,585
Visit site
Hi All,

Managed to get a discount code and an extra 10% with Go Outdoors and purchased a Platinum Leisure Plus Battery S6110L (110ah). However it seemed to struggle when we used the motormover and lost it’s charge quickly. Not known if their was an issue with the battery, but I noticed a lot of corrosion around the negative battery terminal and the connector appeared burnt and the plastic cap cover melted.

I’ve now disconnected the battery and booked the Caravan in to get checked out. Any ideas what the issue might be? I will need a new battery. Following a chat with a sales person at Go Outdoors, he said the battery I had purchased, had a recycle rate of 70, but other stuff had 360 and as high as 640. I was thinking of getting a banner originally, but purchased the, battery from Go Outdoors because of the good deal. The motor mover, has to move a large twin axle Bailey Barcelona Unicorn.

Thanks
 
Nov 16, 2015
10,908
3,203
40,935
Visit site
A question, did you clean the battery terminals on the battery leads before connecting to the new battery and then charging the battery before using the motor mover. ?
 
Nov 16, 2015
10,908
3,203
40,935
Visit site
I would try cleaning up the terminals fully first with a bit of wet /dry paper, so you have a clean contact, then a charge and try again, also are the Motor mover cables into the terminal connectors nice and tight. Any slackness can cause the MM not to perform. I have also found the MM connecters at the fuse block to be slack. Just check them all out and Good luck.
 

TRENDING THREADS

Latest posts