Apple ipad internet connection problems

Jul 30, 2007
Been with Talktalk for 5 years now with no problems.
However,wife is now unable to connect to internet on her Apple ipad(8th Gen.).
My own android phone,her android phone,and tv(Netflix etc) problems.
The error message she gets on the ipad is "Weak security....WPA/WPA2 (TKIP) is not considered secure"
"Configure the router to use WPA2 (AES) or WPA3 security type".
Not being too "IT savvy",im confident to try this suggestion but hopefully,it wont interfere with phones/tv which seems to be working ok.
I know I could contact Talktalk,but was wondering if any members here could shed some light on this ipad connection problem and if I should go ahead with the router changes.
Many thanks.
  • Like
Reactions: Hutch
Nov 17, 2005

The problem does not lay with your Internet Service Provider unless they have provided your router as part of your package.

The issue is the level of security you have set on your router wi-fi.

This is a short summary of Wi-Fi security to date.

WEP – Wired Equivalent Privacy is the oldest and the least secure Wi-Fi encryption method around since the 90s. It is not good. The encryption can be broken, and then any data you send can be read by a hacker.

WPA/WPA2 – Wi-Fi Protected Access, WPA, adds an additional layer of security to WEP, but was sort of a temporary fix until WPA2. WPA2 is a common security protocol being used on routers today. Although there are some vulnerabilities, its still pretty secure. WPA2 can be either TKIP or AES. You want AES as it is the newer, more secure of the two.

WPA3 – The latest security protocol, adds a much stronger encryption which significantly improves the security of your Wi-Fi.

The most secure is WPA3 but because this is the newest protocol, it is not supported by some older devices. If you have older devices, you may need to go with a lesser security protocol.

The message you get is saying that your new ipad (8th Gen) sees that your security is as the older WPA/WPA2 (TKIP), which it considers to be too weak and you need to update this to at least WPA2 (AES).

As of February 2021 Apple did support these for backward compatibilty purposes but reserved the right to remove this in newer versions of their software.

Before doing anything else, you will need to go into administrative functions within your Router to first check it is capable of running the later levels of security and also check that your other devices are compatible with the newer levels also.

If you can't verify this and like me your router comes as part of your package then you will have to raise the issue with TalkTalk.

I hope this helps.
  • Like
Reactions: otherclive
Jul 30, 2007
Thank you Firkle for your very informative reply.
Rather than try to go into settings etc.I gave Talktalk a ring,explained the problem and they sent an engineer out yesterday.
After doing his checks on our system,he discovered a fault with the cabling further down our street.
2 hours later he returned and powered up the router,mine and wifes phone plus the Apple ipad.
All now working perfectly and speedier connection.

Over the moon now👍
Thank you once again for your help🍻


Latest posts