ALKO ATC red light and no initiation...

Aug 12, 2019
I had an issue with the ATC led not lighting at all, but everything behaving as it should apart from that and concluded that the LED was blown, or at least the green part of it was. Research on forums such as this one suggest they tend to fail from corrosion and water ingress.

With the LED removed from the caravan (and the open end of the connector taped over to keep it clean and dry) the ATC still went through its initiation test when plugged in and was apparently working,

Having repaired the LED assembly (being the sort of practical guy who thinks he can fix anything, usually successfully) I now have system that lights the red light as soon as it is plugged in and doesnt do the setup test anymore (which it did before I repaired the LED).

I have left it plugged into the car for well over 12 hours, as per instructions to "clear the memory if full" and find it the same this morning.

Getting more technical:
Cutting into the failed led unit after removing it showed that it is just a bi colour two leg led which is green with the current going one way and red with the current going the other. Testing with my meter lit the red but reversing didn't light the green (so the green was blown). There were no resistors in series to this plain LED so the current limiting resistors must be inside the control box surely? I identified several bi colour two leg leds and spec sheets were all very similar so (as per posts about repairing these things in other forums and here), I agreed with the idea that any led will work, or a pair with one connected one way and one the other.
Anyway I fitted a two leds in opposite orientations and put these in the housing. My assembly I just tested and it lights red one way and green the other with no shorts. There are only two pins....

However it would appear that connecting this has either confused or blown something in the ATC controller. But I dont see how that happened...and it sounds expensive. And after I just saved £30 fixing that led assembly :angry:

Vehicle supply under volts? Well I tried it with engine running and not running and the vehicle battery turns its starter well enough...
Power must be on the necessary pins or it wouldn't light anything..

I was careful to get the LEDS the right way round as I established that the RED+ was on the brown wire on the LED assembly as it was.

The Red led comes on without any hesitation, as soon as the unit is connected. Nothing moves.
Ive backed up and pulled a bit to be sure its not the hitch/brake movement in the wrong place.
Next stage seems to be drive it about with the red led on and the system inactive and see if it goes green? Its a bit of hassle to do that when not actually going on a trip...but I don't understand why that might work...

I also don't understand how leaving it connected for ages without driving it would fix the memory issue, unless it is constantly wringing zero errors or something and takes that long to fill the memory. Seems daft though not to have a way to clear the memory with an instant reset of some sort.

I'm left wondering if I have missed something obvious. Hand brake is off...mains disconnected, 12v on on the caravan - and as I said it was previously doing the initialization.


May 7, 2005
Have you checked it reverts to working as it did before your deeper "experiments"?

"With the LED removed from the caravan (and the open end of the connector taped over to keep it clean and dry) the ATC still went through its initiation test when plugged in and was apparently working",
Aug 12, 2019
Yes, unfortunately with the LED disconnected there is no initialization like there was before.

But I cant find anything wrong with my LED assembly...
Aug 12, 2019
There is no problem getting the 2 leg bi colour leds, I just used two single ones cos I had them already.
The 5mm re/green 2 leg led:
eBay item number:290985744089 (5 for £2.40 inc shipping)
Farnell 1142560

RS and Farnell might be expensive for postage without a business account I guess.

The original assembly is just one of these with wires soldered on and pushed into the solver housing retained with a load of silicone sealant. The glass part unscrews and you can push it all out from that end. The legs of my led were well corroded and as I said above it failed to light in the green direction when tested, but the red still worked.
Some people are filling both ends with clear epoxy to get it to last longer. Some are putting an extra resistor in series but I don't think that is the issue, its water ingress and corrosion rather than it running too hot. But £30 for the led assembly is a rip off if you can solder and have some heat shrink... (burt not if your repaired one somehow screws the controller up!) :eek:hmy:
Aug 12, 2019
I think my last chance is that my old terrano isn't giving the thing enough volts anymore - which is into the realms of unlikely coincidences.
A neighbour down the street has a similar caravan, I might see if he will connect his car to mine, or let me try his caravan on my car.
Aug 12, 2019
All is good.
the initiation must be pretty fussy about the supply voltage because although the terrano was spining and starting fine volts were only 12.3.
In one last attempt I fired the car up and revved the engine for a bit and the ATC initialised and the led went green.
So I guess i have just been moving my truck about and not giving it a drive out. I'm a bit more careful about that in the winter. In the last month it only went across the village for its mot.


Jun 25, 2021
The LEDs stop working for some reason. It is corrosion. Water ingress. It overheats in the sun. Or dampness. If it is wet, you will immediately understand. We'll all be rusty. But it will be more challenging to overheat in the sun. You won't see anything. No rust. No dampness. Everything will remain as it was. It is a widespread problem. Few people can understand that this is overheating. But this is solvable. You need to take it for repair. So it's not about the car. Or in her system. Just a problem with the LED. Sometimes you can do it yourself. But it will work for you for a couple of hours, especially if they are ordered from Amazon.
Last edited:
Nov 11, 2009
The LEDs stop working for some reason. It is corrosion. Water ingress. It overheats in the sun.
I really cannot believe that overheating in the sun would stop them working. Caravans are designed to be outdoors, and whilst ATC has been around now for a good number of years I have never heard of that particular reason given.


Latest posts